1
KONFIGURASI ROUTER CISCO MENJADI INTERNET GATEWAY
Pada materi kali ini kita akan belajar bagaimana cara melakukan konfigurasi Cisco router agar dapat difungsikan
menjadi internet gateway pada jaringan Local (LAN) kita. Untuk contoh topologi yang akan digunakan pada materi ini
dapat dilihat pada gambar di bawah ini :
Pada gambar topologi di atas terdapat sebuah router Cisco dengan seri 1841 yang menjadi perantara antara PC di
dalam jaringan Local (LAN) dan Internet (topologi semacam ini disebut dengan internet gateway). Router ini yang
nantinya akan difungsikan sebagai internet gateway agar client yang berada di bawahnya (di jaringan local) bisa
mendapatkan koneksi internet dari ISP lewat modem. Untuk koneksi antara router ke Internet menggunakan media
kabel yang terhubung ke interface fa0/0 dan router ke PC terhubung ke interface fa0/1.
Baiklah, kita akan langsung masuk ke langkah-langkah konfigurasinya menggunakan rangkaian perintah baris (IOS
commands). Silahkan ikuti dan fahami step-by-step konfigurasinya agar kalian tidak gagal faham.
1. Request DHCP client
Konfigurasi pertama ini bertujuan untuk membuat koneksi antara router Cisco dengan router ISP dimana dengan cara
meminta IP addresssecara otomatis dari router ISP ke router Cisco, konfigurasi ini di sebut dengan request dhcp
client. Dalam hal ini router akan meimnta IP addressDHCP ke perangkat modem di jaringan kita. Modem lah yang
sebenarnya akan terkoneksi langsung ke ISP. Berikut langkah meminta IP DHCP client pada router Cisco.
Router>enable
Router#configure terminal
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Router(config-if)#ip address dhcp
*Jun 26 07:33:36.571: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0
assigned DHCP address 192.168.1.254, mask 255.255.255.0, hostname Router
MODEM
fa0/0
fa0/1
192.168.1.1/24
192.168.2.1/24
192.168.2.11/24
192.168.1.254/24
ISP
CISCO ROUTER
2
Jika langkah pertama ini berhasil maka router Cisco akan otomatis mendapatkan IP addressdari modem ISP dan pada
tahap ini seharusnya router Cisco sudah mendapatkan akses internet , Sebelum masuk ke tahap selanjutnya silahkan
cek IP address dhcp client dan lakukan tes ping ke google.com pada router Cisco terlebih dahulu, caranya :
2. Cek IP DHCP Client pada Router Cisco :
Router#sh ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 192.168.1.254 YES DHCP up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/0/0 unassigned YES unset administratively down down
3. Cek ping router ke Google.com
Router#ping google.com
Translating "google.com"...domain server (8.8.8.8) [OK]
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 216.58.216.110, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
204/204/208 ms
4. Buat IP address untuk Interface Fa0/1
Setelah router Cisco sudah mendapatkan IP address dari router ISP dan mendapatkan fasilitas internet, maka langkah
selanjutnya adalah membuat IP address untuk interface yang mengarah ke sisi client (fa0/1), untuk skript nya dapat di
lihat pada skript di bawah ini :
Router(config)#interface fa0/1
Router(config-if)#IP address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
5. Buat DHCP Excluded Address
Untuk langkah ini bersifat opsional namun saya menyarankan untuk tetap melakukan konfigurasi ini terlebih jika router
Cisco nantinya akan di setting konfigurasi dhcp server, konfigurasi ini bertujuan agar menyimpan IP address dengan
range tertentu dan tidak akan di distribusikan oleh layanan dhcp server, caranya :
Router(config)#ip dhcp excluded-address 192.168.2.1 192.168.2.10
Dengan menerapkan cara di atas maka router akan menyimpan IP address dengan range 192.168.2.1 sd 192.168.2.10
dan tidak akan diberikan kepada komputer client di jaringan local.
6. Buat DHCP Server
Konfigurasi selanjutnya adalah dengan melakukan konfigurasi DHCP server yang bertujuan agar router dapat
mendistribusikan IP address otomatis ke komputer client di jaringan local yang terhubung langsung ke router Cisco,
caranya sebagai berikut :
Router(config)#ip dhcp pool IP-Client
Router(dhcp-config)#network 192.168.2.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.2.1
Router(dhcp-config)#dns-server 8.8.8.8
3
7. Buat Name-Server & Access List
Fungsi Name-Server adalah sebagai database domain yang terdapat pada jaringan, umumnya name-server ini diisi
dengan IP address modem atau bisa juga menggunakan IP DNS server public seperti 8.8.8.8, 1.1.1.1. Pada materi ini
IP address modem adalah 192.168.1.1 dapat dilihat pada langkah pertama dimana router Cisco mendapatkan IP
address192.168.1.254, jika anda kurang yakin silahkan lakukan ping ke ip 192.168.1.1.
Sedangkan access list berfungsi untuk memfilter (menyaring) atau membatasi paket berdasarkan IP address dan
diterapkan pada interface. Untuk memudahkan pemahaman silahkan kalian lihat pada konfigurasi di bawah ini :
Router(config)#ip name-server 192.168.1.1
Router(config)#access-list 1 permit 192.168.2.0 0.0.0.255
Router akan membuat sebuah access list dengan nomor index 1 dan action permit (mengijinkan) IP address dengan
network 192.168.2.0 dan wildcard 0.0.0.255 (netmask 255.255.255.0) dan access list dengan nilai 1 ini yang nantinya
akan diterapkan saat konfigurasi NAT overloading. Fungsi ini sebenarnya bertujuan untuk mendefinisikan bahwa
network tersebut diijinkan untuk melewati access list dengan action permit diatas.
8. Buat NAT Dynamic Overload
Network Address Translation pada Cisco terbagi menjadi 2 yaitu static dan dynamic. Untuk NAT Static bersifat one to
one dan Dynamic memiliki beberapa Opsi seperti NAT dengan Pool dan NAT Overload.
NAT Pool umumnya di gunakan untuk teknik load balancing sedangkan NAT Overload adalah NAT yang paling sering di
gunakan untuk konfigurasi Internet Gateway dengan cara kerja semua request atau permintaan beberapa komputer
client di jaringan local yang menuju ke internet akan diberikan ke satu alamat IP global/outside (IP Public). Dengan
cara ini akan menghemat penggunaan IP public pada sisi ISP (Internet Service Provider).
Untuk melakukan konfigurasi NAT Overload pada router Cisco pertama-tama kita harus mendefinisikan interface mana
mengarah ke sumber internet (ISP) dengan cara :
Router(config)#ip nat inside source list 1 interface fa0/0 overload
Pada cara di atas bertujuan untuk mendefinisikan interface fa0/0 yang nantinya akan bertugas menjadi interface
overload atau jalur utama menuju internet, sedangkan skript source list 1 yakni mengijinkan network yang sudah
terdaftar pada access list 1 tersebut untuk menuju ke internet melalui interface fa0/0.
Setelah mendefinisikan interface overload maka selanjutnya adalah mendefinisikan status pada masing-masing
interface tersebut pada menu IP NAT dengan cara :
Router(config)#interface fa0/0
Router(config-if)#ip nat outside
Router(config-if)#exit
Router(config)#interface fa0/1
Router(config-if)#ip nat inside
Interface fa0/0 berstatus interface yang akan mengarah ke jalur internet (outside) sedangkan Interface fa0/1 berstatus
yang akan mengarah ke sisi client local (inside). Pada tahap ini seharusnya konfigurasi internet gateway pada router
Cisco telah selesai, untuk pengujian dapat di lakukan pada sisi client dengan cara :
9. Cek IP addressPC
C:\Users\L412>ipconfig /all
Windows IP Configuration
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::d1cd:
IPv4 Address. . . . . . . . . . . : 192.168.2.11
4
Subnet Mask . . . . . . . . . . . : 255.255.255
Default Gateway . . . . . . . . . : 192.168.2.1
PC sudah mendapatkan IP addressdari router yaitu 192.168.2.11
10. Cek Ping dari PC di jaringan Local (LAN) ke google.com
C:\Users\L412>ping google.com
Pinging google.com [216.58.216.110] with 32 bytes of da
Reply from 216.58.216.110: bytes=32 time=204ms TTL=34
Reply from 216.58.216.110: bytes=32 time=203ms TTL=34
Reply from 216.58.216.110: bytes=32 time=204ms TTL=34
Reply from 216.58.216.110: bytes=32 time=204ms TTL=34
Test ping dari PC client sudah terlihat hasil reply from 216.58.216.110. Yang menandakan bahwa PC di jaringan Local
sudah bisa terhubung ke internet melewati router Cisco. Dalam hal ini router Cisco berfungsi sebagai gateway internet.
Demikian 10 langkah mudah mengkonfigurasi router Cisco sebagai gateway internet agar dapat menghubungkan
banyak client di dalam jaringan local ke internet. Semoga bisa difahami dalam rangka menambah pengetahuan dan
skill kalian di bidang manajemen jaringan menggunakan perangkat Cisco.
Wonosobo, May 2021
TKJ Department
SMK Informatika Wonosobo
www.smkinka-wsb.sch.id
Presented by
Nurulhadi Hammamy, S.Kom
0822-2556-0911